Trolling Motor

Moderators: MKA, Mike M, Caudawg, ash

jfent72
Posts: 7
Joined: Wed Jun 27, 2012 3:06 pm

Trolling Motor

Postby jfent72 » Mon Jun 17, 2013 9:53 pm

I recently bought 2 new batteries for my 12v trolling motor but they only lasted for an hour. When I put them on the charger they read full but the TM would not work. Anyone have any idea what the problem maybe?

eagle123777
Posts: 642
Joined: Wed Jun 08, 2005 1:47 pm
Location: manteca, ca

Re: Trolling Motor

Postby eagle123777 » Tue Jun 18, 2013 3:13 am

a new battery doesn't mean a good battery. check them with a meter or take them to a auto store to have them checked. if they are good u probably have a wiring problem, check ur TM plug for corrosion and loose wires at the connection, that happens a lot. its 12v so not to many things to check
jack
usaf (ret)
triton 21x2

User avatar
minnkotaman
Posts: 159
Joined: Wed Apr 18, 2007 12:04 pm
Location: SAN RAMON

Re: Trolling Motor

Postby minnkotaman » Tue Jun 18, 2013 7:07 am

pull your prop and make sure your not loaded with fishing line.

GW
Posts: 631
Joined: Sat May 07, 2005 7:24 pm
Location: Rocklin, Ca

Re: Trolling Motor

Postby GW » Tue Jun 18, 2013 7:20 am

you said you purchased 2 new batteries......how do you have them wired?

User avatar
TeamBeefmaster
Posts: 154
Joined: Tue Dec 14, 2010 9:02 pm
Location: Castaic

Re: Trolling Motor

Postby TeamBeefmaster » Tue Jun 18, 2013 11:39 am

yes- how are you wiring them? two batteries in series makes 24 VDC - not sure what that will do to your motor! They need to be in parallel. hope that fixes it


Return to “Fishing”

Who is online

Users browsing this forum: Mattyq17 and 47 guests